AWS me-central-1 Availability Zone Outage

Incident Report for Kurrent Cloud

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 01:28 UTC

Update

AWS continues to recommend their customers with resources deployed in the Gulf regions impacted by the conflict in the surrounding areas should migrate their workloads to other regions, such as those in the EU. We have worked with our customers who have been impacted to assist them with migrating to other regions.
Posted Mar 11, 2026 - 01:27 UTC

Monitoring

Per AWS: At around 4:30 AM PST 1 Mar 2026, one of the Availability Zones (mec1-az2) was impacted by objects that struck the data center, creating sparks and fire. At 10:46 PM PST it was confirmed a second AZ (mec1-az3) was impacted by "localized power issues" causing EC2 API and instance launch error in mec1-az1.  At 12:52 AM PST 2 Mar 2026, AWS posted that it is not currently possible to launch new instances. The 6:22 AM PST update stated recovery of the two impaired Availability Zones (mec1-az2 and mec1-az3) in the ME-CENTRAL-1 Region is expected to take at least a day.

We will continue to monitor the situation. We encourage customers to check the AWS Service Health page for the most recent updates.
Posted Mar 02, 2026 - 14:43 UTC
This incident affected: Provisioning AWS.